Microsoft Lync Server 2010 Infrastructure Requirements

All servers running Microsoft Lync Server 2010 must meet certain minimum system requirements. Each server of Lync Server must have minimum requirements which listed on installation guide.

This documents describe these minimum requirements which need us when buying hardware or installation . 32-bit edition of Lync Server 2010 is not available . Only 64-bit edition of Lync Server 2010 is available. We can only use 32-bit planning tool.

Hardware recommendations for Lync Server 2010

CPU – 64bit dual or quad core 2.0 GHz or higher

Memory – 16 GB

Disk – 72 GB free disk on SAS or NL-SAS disk

Network – 2 Ethernet 1 Gbps or higher

Hardware recommendations for DB Servers

CPU – 64bit dual or quad core 2.0 GHz or higher

Memory – 32 GB

Disk – 72 GB free disk on SAS or NL-SAS disk

Network – 2 Ethernet 1 Gbps or higher

Hardware Recommendations for Archiving and monitoring DB servers

CPU – 64bit dual or quad core 2.0 GHz or higher

Memory – 16 GB

Disk – 72 GB free disk on SAS or NL-SAS disk

Network – 2 Ethernet 1 Gbps or higher

Operation systems for Server Roles of Lync Server 2010

Windows Server 2008 R2 Standard Edition

Windows Server 2008 R2 Enterprise Edition

Windows Server 2008 R2 Datacenter Edition

Windows Server 2008 Standard Edition with SP2

Windows Server 2008 Enterprise Edition with SP2

Windows Server 2008 Enterprise Edition with SP2

Database software requirements

Microsoft SQL Server 2008 R2 Enterprise Edition 64-bit

Microsoft SQL Server 2008 R2 Standard Edition 64-bit

Microsoft SQL Server 2008 Standard Edition 64-bit with SP1

Microsoft SQL Server 2008 Enterprise Edition 64-bit with SP1

We can use SQL 2005 but I don’t recommend it. And also SQL server web edition and workgroup edition are not supported. Besides Lync Server 2010 does not support native database mirroring.

For monitoring server role of Lync 2010 you should SQL server reporting service.

Additional Software requirements

  • PowerShell command-line interface 2.0
  • Microsoft.NET 3.5 SP1
  • Windows Installer 4.5
  • For Frontend server and standard edition server you must run these modules with IIS
  • Static Content
  • Default Document
  • HTTP Errors
  • ASP.NET
  • .NET Extensibility
  • Internet Server API (ISAPI) Extensions
  • ISAPI Filters
  • HTTP Logging
  • Logging Tools
  • Tracing
  • Windows Authentication
  • Request Filtering
  • Static Content Compression
  • IIS Management Console
  • IIS Management Scripts and Tools
  • Anonymous Authentication (This is installed by default when IIS is installed.)
  • Client Certificate Mapping Authentication

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

Up ↑

%d bloggers like this: